DesignaKnit 7 Language packs are required for version 7.19.00 or earlier. The current version is 7.20

Language Pack All program versions
English (International) dk7uk.exe
English (American) dk7us.exe
Dutch dk7nl.exe
Finnish dk7fi.exe
French dk7fr.exe
German dk7de.exe
Norwegian dk7no.exe
Swedish dk7se.exe